
Revit course notes and video descriptions 

 

- Jump to the BIM 201 - Intermediate course 

- Jump to the BIM 322 - Revit Plumbing course 

BIM 101 – Beginner course (77 videos): 

Lesson 1: 

Video 1 – Introduction to Revit and Revit file types. Hierarchy of elements. 

Video 2 – Creating a new project using a generic template. Turning off tool tabs in the Revit interface.  

Video 3 – Explaining various basic commands in the ribbon on top. Explaining the Properties Pallet, 

the Project Browser on the left side, the View Control Bar on the bottom, and the Selection Options 

on the bottom right. 

Video 4 – Adding a shortcut for a folder. Explaining the functions on the mouse. 

Video 5 – Miscellaneous stuff. Hiding stuff in a view. 

Video 6 – Creating new view types. Creating a callout. Right-click on callout boundary to go to view. 

Toggling Thin Lines. Hiding Grids. 

Video 7 – Bringing back the gridlines that were hidden using Visibility and Graphics Overrides. Using 

Visibility and Graphic Overrides to hide/show elements. Using Materials/Object Style in the Manage 

tab to change colors of elements. Using Visibility and Graphics Overrides to overrides the 

Materials/Object Style setting in a particular view. Setting Line Weights through the Additional 

Settings button in the Manage tab. 

Video 8 – Moving grid lines and the cautions that need to be taken.  

Video 9 – Creating Building Section views. Change to “Tiled View” in the View tab to view 2 pages at 

the same time. 

Video 10 – Viewing the project in 3D. Using the Section Box. 

Video 11 – Switching from the Orthopedic View to the Perspective View in 3D. Using the Camera 

View in 3D. Turning on the Shadows, turning on the Shading View (colors), and adjusting the 

Lighting and Sun - use the Visual Styles (bottom left). Adding a Silhouette and Sketchy Lines (jitter). 

Video 12 – Creating our first project – The Habitat for Humanity house. Opening a Revit model that’s 

already been set up. 

Video 13 – Setting and adjusting the datums (levels). Setting the Wall Type and choosing the proper 

Location Line.  

Lesson 2: 



Video 1, 2, and 3 – Drawing walls. Using the Aligned Dimension tool and using the Tab button to pick 

edge/center of wall. Changing the Scale. Using the “EQ” option to locate walls equally. Creating a 

new wall type with the parameters that you set. 

Video 4 – Finishing drawing and dimensioning walls. 

Video 5 – Adding doors. Using the Move Tool. 

Video 6 – Continuing to add doors. Using the Align Tool to place doors. Changing the door 

parameters. 

Video 7 – Adding windows. Edit Type of window to adjust size. Setting the sill height. Using the 

Aligned Dimension tool to set window locations. Using the Temporary Dimensions to set window 

locations. Using the Align Tool to set window locations. 

Video 8 – Looking at the model in 3D. Using the Create Similar command to add more windows. 

Changing the View Range to see all items in a wall. Using the Plan Region tool under Plan Views in 

the View tab to edit the View Range for select locations. 

Video 9 – Creating a floor. Editing floor type. 

Video 10 – Creating a roof. Defining the overhang dimension. Defining the slope of the roof. Attaching 

the walls to the roof. 

Video 11 – Adding plumbing fixtures. Loading new fixtures from AutoDesk Families. 

Video 12 – Adding a kitchenette (cabinets, sink, and appliances already combined). 

Video 13 – Defining Rooms and adding Room Tags. Creating a room boundary line with the Room 

Separator tool. Changing room names. Relocating Room Tags and adding leaders to the tags. 

Changing the Arrow on the Leader to a Dot. 

Video 14 – Adding dimensions. Using the “EQ” option. Using the “Edit the Witness Lines” to pick back 

up on where you left off. Adjusting the Project Units (measurement units). Suppressing 0’ and 

suppressing spaces in the measurements. Adjusting the text (measurements) in relation to their 

location on the dimension string. Relocating the measurement text away from the dimension string on 

tight dimensions. 

Video 15 – Toggling EQ to toggle between EQ and the actual dimension. Using the Create Similar 

tool to create a similar type measurement string. Adding text (example - TYP) to a dimension. 

Video 16 – Adjusting the View Range for the roof. Adjusting the Underlay to adjust or eliminate 

transparency through the roof. Changing the Visual Style (bottom left) to Wire Frame to be able to 

see walls through the roof. Using the Line Work tool in the Modify tab to change the line styles (such 

as Hidden Lines). Adjusting the roof overhang dimension. Using the Spot Slope tool to label the roof 

slope. 

Video 17 – Creating Sheets for the drawings. 

Video 18 – Establishing the Crop Region for views. Putting views on the sheets. 

Video 19 – Adjusting the Level Lines on the elevation views. 



Video 20 – Printing Sheets to PDF. Explaining the printing options. 

Video 21 – End of lesson. Pretty much nothing. 

Lesson 3: 

Video 1 – Introduction to lesson 3. Pretty much nothing. 

Video 2 – Opening the pre setup Revit template to start the next project – The Office Building. 

Video 3 – Establishing/modifying the Datum elements such as the levels of the building using the 

Elevation view. 2 options for adding levels to a project. Creating a Plan View for any level. 

Video 4 – Adjusting wall options (type, location line, and top constraint). A quirk with Revit in using the 

Rectangle option for creating walls (be sure to go from the top down, and to the right when creating 

rectangle). Converting Temporary dimensions to Permanent dimensions (but they go to centers of 

walls. To fix, toggle the button at the witness line or drag the witness line.).  

Video 5 – Adding vertical grids to the building (Grid Option in Architecture tab). Be sure to draw grid 

lines in from the bottom to the top to have the Grid Bubbles at the top. Renaming the grid lines. 

Locating the grids.  

Video 6 – Adding horizontal grids. Using the Copy tools to add more grids. Adding dimensions to 

grids. Using the “EQ” option to set grid locations. 

Video 7 – Double checking everything. Checking the 3D view. 

Video 8 – Adding interior walls. Using the Copy tool to add a wall. Using the Trim tools (Trim/Extend a 

corner) in the Modify tab. Using the Split Element tool and Trim (Single Element) tool to modify a wall. 

Using the Split Element tool (Delete Inner Segment) to modify a wall.  

Video 9 – Using the Temporary Dimension option and the “EQ” option to set a wall location. Using the 

Mirror/Pick Axis tool in the Modify tab to place walls.  

Video 10 - Using the Mirror/Pick Axis tool in the Modify tab to place wall. Using the Split Element tool 

and Trim/Extend a Corner to modify walls.  

Video 11 – Using the Offset tool after adjusting the value of the offset (and deciding whether to Copy 

or not) to place walls in the lobby. Using Trim/Extend a Corner & Trim/Extend Single Element to fine 

tune the new walls. And then adjusting the height of the walls in the Properties Panel. 

Video 12 – Checking the progress in the 3D view.  

Video 13 – Changing the wall types of the walls that we’ve already drawn. Selecting all of the interior 

walls using a “Crossing”. Then using the Filter Option to uncheck some items. 

Video 14 – Making changes to the exterior wall in the 3D view (at the entrance) by using the Edit 

Profile tool.  

Video 15 – Splitting an exterior and interior wall using the Split tool (leaving Delete Inner Segment 

unchecked). Using the Align tool in the Modify tab to align the walls. Changing the Detail Level 

(bottom left) to Medium. Changing to Thin Lines. Using the Wall Join tool in the Modify tab to join 

the interior and exterior walls. 



Video 16 – Adding doors. Using the Mirror/Pick Axis tool to add doors. Using the Create Similar tool to 

add doors. Loading Family of doors to find a new door type. Using a Crossing and the Filter 

command to select doors to copy them to the clipboard to paste (Aligned) to level 2. 

Video 17 – Adding windows. Selecting a window that’s close to what we’re looking for in the 

Properties Panel. And then hit Edit Type, and Duplicate view to make a new window size. And then 

adjusting the parameters for the new size and sill height. Using the Mirror/Pick Axis tool to place 

additional windows. Then going to the elevation view, right clicking on 1 level 1 window and selecting 

All Instances, then using Copy (not copy to clipboard) to copy the level 1 windows to level 2. 

Video 18 – Drawing ribbon windows using the Curtain Wall command. Adding Reference Planes to 

begin. Setting Reference Plane locations. Using the Mirror/Pick Axis tool to copy locations. Select the 

Wall tool, then select Curtain Walls in Properties, then check Automatically Embed in the Edit Type to 

place windows. Changing window parameters (such as mullions and other things) in the Edit Type 

box.  

Video 19 – Double checking the size of the ribbon windows in Edit Type. Changing the bottom and 

top constraints. Using Create Similar to add additional ribbon windows on level 1. Use Control to 

select both level 1 ribbon windows in the 3D view, then copy to clip board, then use the Paste/Aligned 

option to place the same windows on level 2. 

Lesson 4: 

Video 1 – Creating the level 1 floor slab. Edit Type and Duplicate to create new floor type. Adjust 

parameters. Click into the Materials section, then click browse to go to the Material Library, then 

select concrete. Change the surface pattern by clicking on Sand and then clicking on “No pattern”. 

Leave it “Concrete” in the Cut Pattern.  

Video 2 – Creating the level 2 floor slab.  

Video 3 – Adding ceilings on level 1 on the Ceiling Plans. Adjust parameters in the Properties tab. 

Using the Automatic Ceilings option. Use the tab key or use a Crossing to select ceilings. Use Edit 

Type to change a ceiling type. Create a new type by hitting Edit Type and Duplicate, and then change 

the parameters. The Sand Pattern works good for drywall ceilings. 

Video 4 – Adding ceilings on level 2 on the Ceiling Plans. Moving the ceiling grid layout around. 

Video 5 – Creating the roof plan. Go to Roof in the Architectural tab. Choose a roof type from the 

Properties Menu. Uncheck Defined Slope in the Options bar to gain access to more tools to use. 

Video 6 – Adding ridge lines and low points on the roof. Use Add Split Line option to establish ridge 

lines. Then go to Sub Elements in the Modify tab to set the height of the ridge lines. In the Options 

Bar, set the Elevation Base to Top Plane and change the elevation to 8” (or whatever). To add the low 

points, select the Add Point option. Then go to Sub Elements to set the height of the low points to 0” 

(or whatever). It will automatically add the Value Lines (slope lines) to the drawing. 

Video 7 – Adding annotations to the roof to add Spot Slope and Spot Elevation. The instructor uses 

¼”/ft for slope on flat roofs. For Spot Elevations, you can select what elevation you want (i.e. top of 

steel, top of finish roof, etc.). Changing the Leader Arrow to 1/16” dot filled in Edit Type. 



Video 8 – Choosing whether the steel or the insulation creates the slope. Go to the Section button in 

the Quick Launch bar at the top to create a section. Double click on the section tag to view the 

section. Change Detail Level to medium to see individual parts of the construction of the roof. To 

change the method used to create the slope, go to Edit Type, select one of the layers (i.e. insulation) 

and change it to Variable which will make the insulation create the slope. Attaching walls to the roof. 

Select All Instances to attach all of the walls to the roof. To join the roof & the walls and the floors & 

the walls on the drawing, go to the Modify tab and select Join. Then select items to join. 

Video 9 – Drawing the curtain wall at the entrance. Adding the vertical grids using the Curtain Grid 

option. Adding the horizontal grids. Changing one of the bays to a door – use the Curtain Grid option, 

using the One Segment, set the horizontal grid at the top of the door for however high the door will 

be. Use Add/Remove Segment to remove the horizontal grid from the middle of the door. 

Video 10 – Changing the panel at the door location to a door (you don’t use the regular door 

command for curtain wall doors) – set it to a System Panel type that is a door in Properties. Since 

there are no door types in Properties, use Edit Type, then select the Option to Load, then Load. In the 

Imperial Library, select a door, and then load. It will then show up in Properties. Adding mullions 

(Architectural tab, Mullion). Select a corner mullion for the corner. Use the All Grid Lines to place all of 

the mullions on a wall at the same time. Delete one mullion at the base of the door. 

Video 11 – Adding the stairs. Start on level 1. Select Stair in the Architecture tab. Select stairs in 

Properties. Adjust Run Width (3’ – 8” in this instance). Draw stairs off to the side at first. Use the Move 

tool to move the stairs into place, with the bottom run in the position that you want. Then use the 

Move tool again to move the top run into place. Then click Finish. Adjust the annotation if desired. 

Then select both the stairs and the annotation and use the Mirror/Pick Axis tool to copy the stairs to 

the other end of the building using grid line 3 (center) as the axis. 

Video 12 – Modifying the floor boundary on level 2 to accommodate the newly added stairs. Select 

floor, select Edit Boundary, use the Lines tool to add new lines around the stairs, and then use the 

Trim tool to delete unneeded lines. Then click Finish. When a warning pops up, click Do Not Attach.  

Lesson 5: 

Video 1 – Adding furniture. Go to Insert and then Load Autodesk Family. In the Imperial Library, look 

for furniture. Select the chairs, cabinets, and shelving that are wanted and click Load. Then select 

Component in the Architecture tab. Then select items that were loaded in the Properties tab. Place 

them where you want, using the space bar to rotate items. Creating a Model Group with one set of 

furniture – select the items wanted, then select Create Group, and then name the group. Then select 

the model group and use the Mirror/Pick Axis tool to copy that group into the other offices using walls 

as the axis points. Then select one group, right click and choose Select All Instances, copy, then use 

Paste Aligned to selected levels to paste them to level 2. When adding a new piece of furniture to a 

group, select the group, then select the Edit Group tool, then use the Add option to add the new 

furniture to the group. Then click Finish. 

Video 2 – Adding plumbing fixtures. Select Component on the Architecture tab. Select the fixture in 

the Properties tab. Use Space to rotate the fixture. Load Autodesk Family to find toilets and other 

fixtures. Copying one group of plumbing fixtures and pasting into another bathroom using the wall as 



the reference. Then copy all fixtures on level 1 using the Copy to Clipboard tool and use Paste 

Aligned to select level 2. 

Video 3 – Adding a room separator – select Room Separator from the Architecture tab. Adding rooms 

with Tag on Placement selected. Renaming the rooms and room numbers. Tagging multiple rooms at 

one time. Using the Dropdown to select room name after at least one of those types have been 

named. Relocating room tags – add a leader and change the leader arrow to 1/16” dot filled. Then 

repeat the same process for level 2. Changing room tags to include area – Right click on one of the 

tags, choose Select All Instances on Project, then change to Room Tag with Area. You will have to 

replace the room tag leaders since they got deleted when the Room Tag Type was changed.  

Lesson 6: 

Video 1 – Adding a Color Fill Legend – Click Annotate tab, then Color Fill Legend, then select Rooms 

and Department on the pop-up menu. Then assign departments for all of the rooms by selecting all 

rooms of one type (i.e. Office, Restroom, Conference Room, etc.) and select Department in the 

Properties tab, then select name (Administration for example). To change Color Scheme colors, 

select the Color Fill Legend, then select Edit Color Fill Scheme. Tip – use the Crossing to select 

multiple rooms. 

Video 2 – Cleaning up and adjusting the drawing. To change furniture colors – select Object Styles in 

the Manage tab, select furniture and change the color. To change furniture to the same colors as the 

rooms – select the Color Fill Scheme, then change it to Foreground in the Properties tab. To clean up 

the stairs view – select Visibility/Graphics Override, go to stairs, then you can turn off items that are 

above the cut line (such as supports, riser lines, and railings). To change the size of the color 

swatches or text at the Color Fill Legend – select Color Fill Legend, then Edit Type in the Properties 

tab. 

Video 3 – Working on building elevation drawings. To shorten the grid or level lines on the elevation 

drawings without also effecting the lines on the floor plan drawings, tighten up the crop region on the 

elevation drawing first (changes the lines from 3D to 2D). To add a heavy line at the base of the 

building – use the Fill Region tool in the Annotate tab, change the type to “Solid Black” in the Type 

Selector in the Properties tab, switch view to Thin Lines, use the Rectangle tool to draw along the 

base of the building (setting it about 1’ tall). To break the section cut symbol line – click on the break 

in the middle and drag the ends to the desired location. To add colors – change the Visual Style at 

the bottom left from Wireframe to Shaded.  

Video 4 – Turn on Shadow (bottom left) to add depth to the elevation drawing. To change Shadows, 

Sketchy Lines, Depth Cuing, Lighting, Realistic, and Background, go to the Graphics Display option in 

the Properties tab and click Edit. Adjust the sun direction in the Sun Settings. To change the colors of 

the objects on the elevation drawing (such as the glass), select a glass panel, then click Edit Type in 

the Properties tab. Then click the button next to “Glass” to open a settings dialog box. Then change 

shaded Appearance. 

Video 5 – Making adjustments to the Building Section drawing and the lobby. Creating a soffit. Also 

creating a “soffit wall”. Adding a railing. 



Video 6 – Using the 3D Camera tool. Making adjustments to the 3D view – adding and adjusting 

shadows and adjusting lighting. Using the Sketchy Lines tool. Turning on Extensions for the 

appearance. 

Video 7 – Creating a sheet for the drawings. Making adjustments to the level 1 and level 2 floor plans. 

Switching an “EQ” dimension to the actual dimension. Copying dimension strings from level 1 to level 

2. Hiding the Color Fill Legend on level 2. 

Video 8 – Putting the views (drawings) on a sheet. Deleting the Department Legend on level 2. 

Changing the view numbers. Increasing the size of a view on the sheet – select the crop region, 

select Size Crop at the top, then change the width and height of the view. 

Video 9 – Making adjustments before printing the sheet. Making an adjustment to eliminate some 

ghost lines from level 1 on the level 2 drawing. Printing the sheet.  

BIM 201 – Intermediate course (86 videos): 

Lesson 1: 

Video 1 – Using Design Options – go to Visibility/Graphics Override, change view options if desired. 

Video 2 – Steps to create a design option (bathrooms in this case) – delete rooms and room tags in 

the rooms that the design option will occupy (ignore the warning), select Design Options at the bottom 

bar, select New option set and rename it if desired, also rename the option(s) if desired, note that it’s 

set to Main Model at the bottom bar, change to Option 1 at the bottom bar and most everything goes 

grey, uncheck the Active Only box at the bottom enables work in the options area, click on all of the 

items that you want in the option set using the control key, click on Move to Option Set at the bottom 

bar, repeat all of these steps on level 2, select Design Options at the bottom bar and create a new 

option (option 2), on level 1 go to Visibility/Graphics Overrides, select Design Options, note that it’s 

set to automatic which automatically shows the Primary Option, switch to Option 2 and hit OK (ignore 

the warning) and level will show the design option 1 and level 2 will have the area blank, add a Room 

Separator at the hall to avoid conflicts with surrounding areas, also add a room separator on level 1 at 

the same location, on level 1 go to Visibility/Graphics Override, set to Option 2. Now it is ready to 

draw in the new layout. 

Video 3 – Continuing with the Design Option – drawing in the new walls being sure that Main Model is 

switched to Option 2 at the bottom bar. 

Video 4 – Adding bathroom partitions after selecting Component in the Architecture tab, download 

from Load Autodesk Families if the partitions aren’t already shown in the Properties tab, adjusting the 

size of the partition by selecting Edit Type and then selecting Parameters, then change the depth that 

the partition needs to be, then use the Move tool to put the partition in place, to adjust the width – 

measure the space, then Edit Type in the Properties tab, then change the parameter to the dimension 

that you measured. OR (preferred in this case), Modify the Family so that this is an Instance 

Parameter – select the partition, select Edit Family, go to Reference Level in the Drawings tab, select 

the Width Parameter dimension on the drawing, check the Instance Parameter box at the top, then 

Load it back into the project (for warning – select Override Existing Version), then you can adjust the 

width in the Properties tab as needed, then move into place using the Move tool. Use the Mirror/Pick 

Axis tool to copy it into the men’s bathroom using the center wall as the axis.  



Video 5 – Adding the other partition in the women’s bathroom. Removing the partition side panel in 

the Properties bar. Using the toggle to flip the partition around. Using the Move tool to set it in place. 

Adding the urinal screen in the men’s bathroom. Adding the toilets in the women’s bathroom by 

selecting Component in the Architecture tab. Using the Mirror/Pick Axis tool to place the men’s toilet. 

Adding the urinal in the men’s bathroom. Adding the lavatories. Select all of the elements (plumbing 

fixtures, partitions, and doors) and Copy them to Clipboard, then go to level 2 and use Paste Aligned 

to Current View to place everything on level 2.  

Video 6 – Making adjustments to the door locations in the option. Adding a Handicap ‘circle’ – go to 

the Annotate tab, then select Detail Line and draw a circle with a 5’ diameter using the Circle option, 

use the Hidden line type to make the line dashed, then move it to where it clears all other objects 

(doors, walls, fixtures), and then Copy the circle to the other bathroom.  

Video 7 – Adding the rooms and room tags back into the option – select Room in the Architecture tab, 

note that while in the Main Model option (bottom bar) it uses the original design option regarding the 

room boundaries, change it to option 2 to be able to place rooms/room tags in the new option 

(disregard warning). Do the same things for both levels.  

Video 8 – Creating a callout on level 1 of the design option area by selecting Callout in the View tab 

while being sure that Active Only (at the bottom bar) is off. Level 1 Callout will now appear in the 

Project Browser tab. Rename it to “Level 1 – Restroom option A”. Then right click on “Level 1 – 

Restroom option A” in the Project Browser tab. Then select Duplicate with Detailing. Then rename 

that one to be “Restroom option B”. Then select Visibility/Graphics Override and change Option 2 to 

Option 1 and hit OK. Change to Main Model (bottom bar) and go to Design Options in 

Visibility/Graphics Overrides and set it to Automatic and it will show the Primary Option. If you want to 

change the Primary option, go into the Design Options settings and select Option 2 to Make Primary 

(disregard warning). Changing the Detail Levels to Medium. Override the other option view by 

changing it from Automatic to Option 1. Changing the Option names from options 1 and 2 to options A 

and B. Option B should now be the Primary Option and Option A needs to be the original one (set that 

to option A). Set the other view to Automatic to always show the Primary Option. That will cause the 

room tags to disappear. Go to Annotate and then Room Tag to add them back in. On Option A, we 

had previously eliminated the rooms and room tags. Adding the rooms and room tags back in to 

Option A. Now, do all of those steps again for level 2.  

Video 9 – Adjusting the settings for the views in preparation of putting them on a sheet – change the 

Detail Level to Medium, set the scale to 1/8”/ft. To make these changes to all of the views at the same 

time, select each of them in the Project Browser using the control key, then change the scale and 

detail level for all of them in the Properties tab. Tightening up the grid lines. Creating an 11” x 17” 

sheet and naming it. Putting the views on the sheet. Showing how to move things around on the 

sheet. 

Video 10 – Printing to PDF. Setting the printing options.  

Lesson 2: 

Video 1 – Creating a new family from scratch. Open the “Casework – wall based” template. Changing 

the measurement parameters on the template. 



Video 2 – Modeling a lower cabinet. On the Right Elevation view, use the Extrusion tool to draw a box 

– select Extrusion in the Create tab, use the Rectangle shape to draw a rectangle on the Reference 

Plane lines, lock all of the padlocks since we want the measurements to be constrained, then click the 

green Check to exit the edit mode. Adjusting the length and of the box we drew. Checking to see that 

everything moves along with changes to the dimensions on the reference planes.  

Video 3 – On the Right Elevation drawing, we use the Extrusion tool (in Create tab) to create a toe 

kick. Drawing horizontal and vertical reference planes for the toe kick by selecting Reference Plane 

(RP) in the Create tab, then add dimensions for the horizontal and vertical reference planes, then 

select Align Dimension in the Annotate tab, then click on the horizontal Reference Level (not the 

geometry plane) and the horizontal reference plane that we just created, then do the same thing for 

the original vertical reference plane and the vertical reference plane that we just created, change the 

depth dimension to 3” and lock it so that it will never change, and then we set a parameter for the 

height dimension by selecting the dimension, then in the Modify/Dimensions tab click on the Label 

drop-down and note that “Toe kick” doesn’t exist yet, click the button next to the Label drop-down to 

create a new parameter, name the parameter in the Parameter Properties dialog box “Toe space 

height”, leave it as a Type parameter and click OK, then change the dimension on the drawing to 4”. 

Video 4 – On the Right elevation drawing, select Void Forms and then select Void Extrusion, use the 

Rectangle tool to create a rectangle at the toe space, lock all of the padlocks, then finish the sketch 

by clicking the green check mark. By changing the height of the toe kick, you can verify that 

everything is correct if everything moves. Use the Align tool in the Reference Level drawing to stretch 

the toe kick out to 4’ long since 1’ is Revit’s default measurement, then padlock the dimension to lock 

the constraint. Opening the 3D view and double checking the Family parameters by selecting Family 

Types. Adjust the length in the dialog box to 6’ to confirm that it does get longer. Adjust the height to 2’ 

– 10” to confirm that it does get shorter. Adjust the depth to 3’ to confirm that it does get deeper and 

that the toe kick does move with it. Adjust the height of the toe kick to confirm that it does get taller. 

Then reset all dimensions back to their original dimensions. 

Video 5 – Modeling an upper wall cabinet. On the Reference Level view, draw a Reference Plane 

horizontally across the length of the base cabinet, then draw a dimension from the reference plane 

we drew to “Reference Plane – Back Reference” (check bottom left bar when you hover over wall). 

Then select the measurement, click the button next to the Label button and name the new parameter 

“Upper Cabinet Depth” in the dialog box. Then change the dimension to 1’ – 2”. Go to the Right 

Elevation. Draw (2) horizontal reference planes for the wall cabinet. Draw dimensions from the floor 

reference plane to both the bottom and top reference planes of the wall cabinet. Set the bottom 

dimension to 4’ – 6” and the top dimension to 8’ – 0”. Create a box for the wall cabinet at the 

reference planes by using the Extrusion tool and the Rectangle tool in the Create tab. Then lock all 4 

padlocks. Then finish the sketch by clicking the Green Check mark. Go to the Placement Side 

elevation view, Use the grip to drag the wall cabinet to the same length as the base cabinet. Then 

lock the padlock. To double check everything, go to the 3D view, select the wall cabinet, select Family 

Type, change the length to 6’ – 0” in the dialog box to ensure that everything moves together. Then 

change the length back to 4’ – 0”. Then change the depth to 2’ – 0” to ensure that everything moves 

and then switch the dimension back to 1’ – 2”. 

Video 6 – To have a dotted line appear on the floor plans where the wall cabinets are located, go to 

the Reference Level view, select Symbolic Line in the Annotate tab, click the drop-down at 



Subcategory and select Hidden Lines – Projection. Then uncheck the Chain box on the bar. Then 

draw a line along the reference plane at the front of the cabinet. Then lock both padlocks. To double 

check that the symbolic line moves with the cabinet – on the view, change the wall cabinet depth to 1’ 

– 0” to ensure that the symbolic line moves with the cabinet, then change the dimension back to 1’ – 

2”. Then change the length to 5’ – 0” to ensure that the symbolic line moves. Then change the length 

back to 4’ – 0”. 

Video 7 – To control the visibility of the individual cabinets (sometimes you may not always want both 

cabinets at the same location) – select the wall cabinet, click on Visibility Settings, uncheck the When 

Cut in Plan/RCP box, then click OK. You can also – select the wall cabinet, in the Properties tab in the 

Graphics section there is a Visible option, select the button to the right of the Visible option, a new 

parameter will need to be created since there are none listed in the dialog box yet, click the button at 

the bottom left corner of the dialog box and a new dialog box will appear, name the new parameter 

“Upper Cabinet”, then select Visibility in the Group Parameter Under drop-down, hit OK twice. The 

Symbolic Line for the wall cabinet will also need to be adjusted so that it doesn’t appear in instances 

where there is no wall cabinet – select the Symbolic Line, click the button to the right of the Visible 

option under Graphics in the Properties tab, select “Upper Cabinet” in the dialog box and hit OK. 

Video 8 – Types can now be assigned to this Family before we load it into the project – select Family 

Types, name it “36”H x 24”D with upper” and hit OK, then do the same thing but name this one “36”H 

x 24D” and uncheck the “upper cabinet” in the Visibility section and hit OK, select Load into Project. 

Place cabinet into the drawing at the Breakroom, then select Edit Family, click on the length 

parameter, check the Instance Parameter box at the top and hit Save, click on “Overwrite the Existing 

Version” in the dialog box. Now, grips will appear on the cabinet and it can be stretched out to fit. 

Video 9 – Adding furniture to the breakroom - select Component in the Architecture tab, select Table – 

Dining Round with Chairs in the Properties tab, place the table in 4 locations. Moving the Room Tag 

out of the way. Click on one of the tables and select Rotate at the top to rotate the table to a 45-

degree angle. Rotate all of the other tables. Click on a table and then select Edit Family at the top. 

Showing how the family can be adjusted, such as by changing the diameter. It will automatically add 

chairs as the table size increases. 

Video 10 – Creating a Work Station Family – select the File tab, select New, select Family, select 

Furniture Systems. Explaining why/how this needs to be created. Select file, select Open, select the 

Revit Families folder in the BIM 201 folder, select and open multiple files. Start by opening the chair, 

then select Family Types at the top, ensure that the Shared box is checked and hit OK. Repeat the 

same steps for the Standing Desk and file cabinet. Save the Reference Level view – select Save As 

in the File tab, then select Family, name it “Workstation” and select the folder to save it in. To load 

those 3 families into our Workstation Family – go to the chair view, select Load into Project at the top, 

select Workstation in the dialog box, then place the chair in the Reference Level view, close the chair 

view and go to the standing desk view, repeat the same steps as for the chair, and repeat all of the 

same steps for the file cabinet. 

Video 11 – Loading the rest of the items for the workstation – select Load Family in the Insert tab, 

select Revit Families in the BIM 201 folder, select multiple files using the control key, select Open. 

Then select Component in the Create tab, select 3” x 36” Post in the Properties tab, place the Post, 

use the Align tool to set it in place. Repeat those steps for the 24” x 36” partition panel. Use Copy and 



Create Similar (CS) to place additional panels using the Align tool (AL) to set them in place. Then 

select Component in the Create tab, select the 48” x 24” Standing Desk in the Properties tab and 

place the desk. Repeat those steps for the 72” x 24” Work Surface. Move the chair into place using 

the Space bar to rotate it. Then move the file cabinet into the corner. Click on Save, Overwriting the 

Existing Version in the dialog box. 

Video 12 – Select Component in the Architecture tab in the level 1 view. Select the Workstation and 

place it using the Space bar to flip it. Use the Mirror/Pick Axis tool to add another workstation. Then 

select both of those workstations (using the control key) and use the Mirror/Pick Axis (MM) tool to add 

2 more. And then Mirror it one more time for a total of 6 workstations. Create a vertical Reference 

Plane in the middle of the space. Select all of the workstations using a Crossing and drag them all to 

the center. Check the clearance dimensions on each side. Move the whole group to have at least 3’ 

on each side. Select the 4 bottom workstations and use Mirror/Pick Axis to create 4 more. Select 

those bottom 4 workstations and move them down 3’. Then select all 10 workstations and move them 

to where there is 3’ of clearance between the bottom workstations and the wall. Then Copy all 10 of 

the workstations. Select Paste (Aligned to Current View) in the level 2 view. Move the entire group of 

10 workstations to where the bottom 2 workstations contact the wall on level 2. Move the room tag 

out of the room using the Leader option. Placing the cabinets on level 2 – select the cabinet in the 

Properties tab after selecting Component in the Architecture tab, place the cabinet, then stretch it 

across using the grips.  

Video 13 – Select File, then New, then Family, then Family Templates in the BIM 201 folder, then 

select the Door Tag file. Draw a rectangle using the Line tool and then the Rectangle option. Set the 

horizontal dimension to ½” and the vertical dimension to 5/16”. Divide the box horizontally in half by 

using the Line tool in the Create tab. Then draw a vertical line from the bottom up to the midpoint line 

we just drew. Select Line in the Create tab. Select the Fillet Arc tool, check the Radius box and define 

the radius as 1/8”. Then select each of the 2 lines that make up the corners and it will round them all 

off.  

Video 14 – Creating door tags - select Label in the Create tab. Select Door from the drop down in the 

dialog box. Then also select Mark. Then click the Add button in the top center of the dialog box to add 

Mark as a parameter name to the label. Enter 101 in the Sample Value of the Mark parameter. Then 

hit OK. 101 should appear in the drawing. Click on the number and use the directional arrows on the 

keyboard to center it. You can also change the label type from Opaque to Transparent if you want by 

selecting Edit Type in the Properties tab. Select Label in the Create tab again. Select Doors in the 

drop down. Select Width in the choices below that. Select the Units Symbol at the bottom center. 

Uncheck the Project Settings box, selects Inches from the drop down next to the Units line, change 

the Units Symbol to “ from the drop down and hit OK. Enter 36” into the Sample Value next to the 

Width parameter and hit OK. On the drawing, shrink the text box and center the text in the space. 

Then copy that label into the space to the right. Select that newest label and select Edit Label. In that 

dialog box, remove the width parameter by clicking the Remove button (middle center). Then add 

Height as the new parameter. Then go through the same process that we went through for the Width, 

except that on this one we need to set it to Fractional Inches and set the Sample Value to 84”. And for 

whatever reason (he screwed up), we go back to change the Width to fractional inches too by clicking 

on it, selecting Edit Label, and change it to fractional inches too. Then Save As / Family / and name it 

“Door Tag – Width Height”, and hit Save. Then select Load into Project and hit OK. 



Video 15 – Placing the door tags – he prefers to use the Tag by Category in the annotate tab, but in 

this case we use Tag All - check the Door Tags box in the dialog box, check the Leader box and hit 

OK, drag all of the door tags into their proper positions by using the Move symbol on each tag. The 

reason that all of the tags are so far out of place is because he screwed up. On the original Door Tag 

drawing, our door tag was not centered on the drawing. It should have been moved to center before 

saving the drawing. To tag all of the windows – select Tag All, select Window Tags in the dialog box. 

Changing the Window Tag name to “A”. Select Yes in the warning box. Then tag all of the doors and 

windows on the level that you didn’t do yet.  

Lesson 3: 

Video 1 – Doing some housekeeping on our Save folder by deleting old incremental saves that aren’t 

needed anymore. 

Video 2 – Tagging furniture – select Tag by Category in the Annotate tab, select a table on level 1, 

select Yes on the dialog box asking if you want to Load a Furniture Tag, select Furniture Tag in the 

BIM 201 folder and Family Templates folder, then add the tag to the table. Note that the leader is 

already checked and you have the option to have the end Attached or Free End in the Properties tab. 

Free End gives you more flexibility. Hit Escape twice. Then click on the tag and type in T-1. Select 

“Yes” in the dialog box that pops up so that any additional tables that get tagged will automatically 

have the same T-1 designation. Click on the table and select Create Similar (CS) and then click on 

one of the chairs. Label the chair as C-3 and select Yes in the dialog box. Select Edit Type in the 

Properties tab to add a 1/16” dot on the end of the furniture tag leaders. 

Video 3 – Select Tag by Category in the Annotate tab and click on one of the workstations, select 

“Yes” in the dialog box, select Furniture System Tag in the BIM 201 folder and Family Templates 

folder, add the tag to the workstation, label the tag WS-1, select Edit Type and add a 1/16” dot for the 

arrowhead. Select Tag by Category and click on one of the standing desks using the Tab key to cycle 

through the furniture choices, label it SD-1 and click Yes in the dialog box, Select Tag by Category 

and click on one of the file cabinets, label it FC-2, repeat those steps for the chair and label it C-1. 

Video 4 – Tagging plumbing fixtures – move the Men and Women room tags out of the bathrooms, 

being sure that the Leader box is checked. Select Tag by Category in the Annotate tab and click on 

one of the lavatories, click Yes in the dialog box, select Plumbing Fixture Tag in the BIM 201 folder 

and Family Templates folder, add the tag to the lavatory, label it L-1, click Yes in the dialog box, use 

the Create Similar tool (CS) to tag the other lavatory, then tag the urinal, name it UR-1 and click Yes 

in the dialog box, then tag a toilet, name it WC-1 and click Yes in the dialog box, then tag the other 2 

toilets, then add 1/16” dots for the arrowheads by selecting Edit Type in the properties tab. 

Video 5 – Creating an enlarged Typical Office Layout plan – select Callout in the View tab, be sure 

that it is set to Floor Plan in the Properties tab, draw the boundary line around one of the offices on 

level 1, double click on the callout tag and it will open the view in a new tab, right click on Level 1 - 

Callout in the Project Browser and rename it Typical Office Layout, hide the grid lines by selecting 

them and then right click, then select Hide in View and Element, select Tag by Category in the 

Annotate tab and tag the desk, label it D-1 and click Yes in the dialog box, select Tag by Category and 

tag the task chairs, select Tag by Category and tag the shelving unit, rename it S-1 and click yes in 

the dialog box, select Tag by Category and tag the file cabinet, rename it FC-1 and click yes in the 



dialog box, select Tag by Category and tag the executive chair, rename it C-1 and click yes in the 

dialog box, hide the Crop Region in the bottom bar. 

Video 6 – Tag everything on level 2, most tags will all automatically have the right designations since 

they have already been used on level 1, select Tag by Category and tag the conference room table, 

rename it T-2 and click yes in the dialog box. Creating a Reference View for the Typical Office Layout 

– select Callout in the View tab, then check the Reference Other View box and select Typical Office 

Layout in the drop down, then draw in the callout. To remove the “Sim” label next to the callout – 

select Edit Type and delete “Sim” next to Reference Label and leave it blank.  

Video 7 – Creating a sheet for the floor plans – select Sheet in the View tab, select the 30” x 42”, 

ensure that Detail Level is set to medium or fine and adjust the crop regions on the views to be 

placed, rename the new sheet to A2.1, drag the level 1 and Level 2 floor plans from the Project 

Browser and place them on the sheet, make adjustments as necessary to get everything aligned, 

drag the Typical Office Layout view from the Project Browser onto the sheet. 

Video 8 – Creating the door schedule – select Schedules then Schedule/Quantities from the View tab, 

Filter everything except Architecture to shrink the selection list, select Doors and hit OK, the Schedule 

Properties dialog box will pop up, select Mark to add to Scheduled Fields (you can either use the 

Move button in the middle or just double click on Mark), then add the following: Type Mark, Width, 

Height, Thickness, Finish, Frame Material, Family, and Level to the Scheduled Fields, select the 

paper w/ yellow circle button in the middle to add a new parameter, name it Door Material in the 

dialog box, select the Type button to the right, select Text in the drop down under Data Type, select 

Materials and Finishes in the drop down under Group Parameter Under and hit OK, then move the 

new Door Material parameter up to just above Finish using the Move Up bottom at the bottom, repeat 

those exact same steps and name this one Frame Finish, move it up in the Scheduled Fields list to 

just above Family, then hit OK and the door schedule will open. 

Video 9 – Organizing the door schedule – click on Edit next to Sorting/Grouping in the Properties tab, 

select Level in the Sort By drop down, check the Header box under Sort By, select Mark in the Then 

By drop down, hit OK, note that you can click on the door number and select Highlight in Model and it 

will take you to a view of that door, right click on the Level column and select Hide Column. 

Video 10 – click and drag across the C, D, and E columns to highlight them and select Group 

Headers, Type in “Door Size” on the line above Width, Height, and Thickness, do the same thing for 

columns F and G and name them “Door”, do the same thing for columns H and I and name them 

“Frame”, change the “Frame Material” title to just “Material, change the “Frame Finish” title to just 

“Finish, stretch the J column a little bit wider so that the writing is all visible by dragging it to the right. 

Video 11 – rename the Type Mark for door 101 to “AA” (it’s a double door) and hit OK in the dialog 

box, rename the Type Mark for door 102 to “B” and hit OK, rename the Type Mark for door 113 to “A” 

and hit OK, rename the Type Mark for door 211 to “C” and hit OK. On door 101 – enter ALUM under 

the Door Material column and FF under the Door Finish column and hit OK in the dialog box, enter 

ALUM under the Frame Material column and FF under the Frame Finish column and hit OK in the 

dialog box. On door 102 – enter WD under the Door Material column and hit OK (that will populate all 

of the doors that are Type Marked B, the Door Finish is set as an instance parameter and won’t 

populate all of the other Type B doors (you’d have to enter it on each one), it’s easier to go to the level 

1 floor plan and select one of the Type B doors and right click on it, then select All Instances in Entire 



Project, then enter PT-1 in the box next to Finish in the Properties tab, enter WD in the box next to 

Frame Material, the door schedule will now be populated in those categories for the Type B doors, 

then enter PT-1 under the Frame Material column and hit OK, on door 113 – enter ALUM and FF 

under both Door Material & Finish and do the same for Frame Material & Finish and hit OK, on door 

211 – enter WD and PT-1 in those same columns. 

Video 12 – click on Edit on the Appearance line in the Properties tab, check the Outline box and 

select Wide Lines and hit OK, click on “Door Schedule” at the top and highlight the text, select Font, 

change the Text size to 3/16” and check the box next to Bold and hit OK, go to the A2.1 sheet view, 

drag the Door Schedule from the Project Browser to the sheet, drag the side of the door schedule to 

make it wider so that all of the writing fits on one line. 

Video 13 – Creating a Door Types Legend – select Legends and then Legend in the View tab, name it 

“Door Types Legend” and hit OK, select Detail Line in the Annotate tab, select Wide Lines and use 

the Line tool to draw a horizontal line about 36’ long, click on the Component drop down and select 

Legend Component, then click on the Family drop down in the thin bar at the top and select “Doors: 

Door-Curtain-Wall-Double-Storefront”, change the View in the drop down to “Elevation: Front” in the 

thin bar at the top, Change the Host Length dimension to 7’ – 0” in the thin bar at the top, place the 

door on the Detail Line. Repeat the steps above and select “Door : Single-Flush : 36” x 84”” and place 

it on the line, do the same thing again and select “Doors : Door-Double-Glass : 72” x 84””. Adding 

tags under the doors – select Text in the Annotate tab, select 3/32” Arial for the text in the Properties 

tab, draw a text box under the first door and name it “A – SINGLE STOREFRONT” and hit Enter to 

create a new line and add “AA – DOUBLE STOREFRONT”, drag the text box to center it, name the 

next door “B – SINGLE FLUSH”, and name the last door “C – DOUBLE GLASS”. 

Video 14 -  Add width and height dimensions to all 3 doors using Aligned Dimension (DL), click on the 

width and height dimensions text, check the box for Replace With Text and enter “PER SCHEDULE” 

on both the width and the height of each of the 3 doors, note that the B – SINGLE FLUSH door in the 

center should be dimensioned inside the door frame and the other 2 should be dimensioned to the 

outside of their frames. Add another text box to the glass at the first door and enter GL-1, hold the 

control key and drag that text to the next glass and it will copy, add another text box with “T” at the 

bottom of the glass, copy the “T” to the other glass, then select one GL-1 label and one T label (using 

the control key, then hold the control key while dragging those 2 texts to the door on the far right, 

change that one to GL-2, then copy and paste those two to the other door. Then go to the A2.1 view, 

drag the Door Types Legend from the Project Browser onto the sheet. 

Video 15 – Creating a Multi-Category Schedule – select Schedules and then Schedule/Quantities in 

the View tab and hit OK on the first dialog box. Add Type Mark, Family and Type, Category, Count, 

and Cost to the Scheduled Fields and hit OK. Click on Edit next to Filter in the Properties tab. Select 

Category in the drop down next to Filter By. Select “Does Not Equal” in the next drop down to the 

right from Filter By. Select “Doors” in the drop down farthest away from Filter By. Select Category, 

Does Not Equal, and Windows in the 3 drop downs next to And. Select Category, Does Not Equal, 

and Curtain Panels in the 3 drop downs next to the next And. Select Category, Does Not Equal, and 

Casework in the 3 drop downs next to the next And. Select Category, Does Not Equal, and Specialty 

Equipment in the 3 drop downs next to the next And. Then hit OK. Then click Edit next to 

Sorting/Grouping in the Properties tab, select Category in the drop down next to Sort By, check the 

Header box, select Type Mark next to Then By, then hit OK. Enter $250 in the cost column to one of 



the lavatories and click Ok in the dialog box. Enter $400 for the Urinals and $550 for the Water 

Closets. Add $2,500 for the Workstations, $900 for the SD-1 standing desks, $150 for the file 

cabinets, $500 for the T-1 tables, and $350 for the C-3 chairs. 

Video 16 – select Edit at Sorting/Grouping in the Properties tab, uncheck the Itemize Every Instance 

box and hit OK, select Edit at Formatting in the Properties tab, click on Cost in the fields, select 

Calculate Totals in the drop down at the bottom and hit OK, select Edit at Sorting/Grouping in the 

Properties tab, check the Footer box and select Totals Only from the drop down, check the Blank Line 

box, check the Grand Totals box and select Title and Totals from the drop down, now go to the 

Formatting tab in that same dialog box, select Category and check the Hidden Field box, now go to 

the Appearance tab in that same dialog box, check the Outline box and change it to Wide Lines, and 

hit OK. Click on the Multi-Category Schedule title to highlight it, select the Font tool, change the font 

size to 3/16” and check the Bold box, then hit OK. Select Edit next to Fields in the Properties tab, 

create a new parameter by clicking the Page icon with the yellow circle, select the Check All button 

under the Categories list, change it from an Instance to a Type parameter by clicking the button, 

name it “Sorting”, change it to “Text” in the drop down for Data Type and hit OK, select the Filter tab in 

the Schedule Properties dialog box, he looks at it and doesn’t do anything, then hit OK. Enter an “X” 

into each of the Furniture items, Furniture System items, and Plumbing Fixtures items in the Sorting 

column and click OK on each dialog box. Select Edit next to Filter in the Properties tab, add another 

“And” filter field by selecting Sorting in the first drop down, leave the center drop down as Equals, 

enter “X” into the last drop down on the right and hit OK. Click Edit next to Fields in the Properties tab, 

select the Formatting tab in the dialog box, select Sorting in the Fields, check the Hidden Field box 

and hit OK, drag and stretch the columns wider on the schedule so that all of the words fit on one line. 

Go to the A2.1 sheet view, drag the Multi-Category Schedule onto the sheet from the Project Browser, 

drag and stretch the columns wider so that all of the writing remains on one line. To modify the 

schedule – right click on it and select Edit Schedule, select Edit next to Formatting in the Properties 

tab, select Cost in the Fields, change the Alignment to Right, click on the Field Format button, 

uncheck the Use Project Settings box, change the Unit Symbol to “$” and hit OK, and hit OK again. 

Video 17 – Creating a Room Schedule – select Schedules and then Schedule/Quantities in the View 

tab, uncheck all of the items in the Filter list except Architecture, select Rooms in the Category list 

and hit OK. Add Number, Name, Floor Finish, and Area to the Scheduled Fields in the Schedule 

Properties dialog box, create a new parameter by clicking the page icon (with yellow circle) in the 

middle, name it “Material Cost Per SF”, change Data Type to Number, select Construction under 

Group Parameter Under and hit OK. Select the fx button (Calculated Value) in the middle to create 

another parameter, name it “Total Material Cost”, change the Type to Area, click on the browse button 

to the right of the Formula line, select Area and hit OK, add an * on the Formula line (after Area) to 

represent a multiplication symbol, then click on the browse button again and select Material Cost Per 

SF and hit OK, select the Sorting/Grouping tab in the Schedule Properties dialog box, select Number 

from the drop down next to Sort By, check the Grand Totals box and select Title and Totals from the 

drop down next to it, then go to the Formatting tab, select Area from the Fields, select Calculate 

Totals from the drop down at the bottom, then select Total Material Cost in the Fields, select Calculate 

Totals from the drop down at the bottom, then go to the Appearance tab, check the Outline box and 

change the drop down to Wide Lines, then go back to the Formatting tab, select Material Cost Per SF 

from the fields, select Right for the Alignment, select Total Material Cost from the Fields and select 

Right for the Alignment, select Material Cost Per SF from the Fields (AGAIN!), click the Field Format 



button, uncheck the Use Default Settings box, select Currency next to Units, select 2 Decimal Places 

under Rounding and hit OK, select Total Material Cost in the Fields (AGAIN!), select the Field Format 

button, uncheck Use Project Settings, change Units to Square Feet, set Rounding to 2 Decimal 

Places, set Unit Symbol to None and hit OK, and hit OK again. Select the Isolate button at the top, 

select the room numbers that are remaining by pressing and dragging, select Delete at the top and 

click OK on the dialog box, select Show at the top. Enter “T-1” in the Floor Finish column and “18” in 

the Material Cost Per SF column for room 101. 

Video 18 - Adding more info to the Room Schedule - enter “CP-1” in the Floor Finish column for each 

of the offices (you can find it in the drop down on each line after entering it once), enter “8” in the 

Material Cost Per SF column for each of the offices, enter “CP-2” and “8” for both Halls, “R-1” and “4” 

for each of the Stairs, “T-2” and “12” for both Men and Women, “LVT-1” and “10” for the Break Room, 

“CP-3” and “8” for both Open Offices, and “CP-2” and “8” for the Conference Room. Highlight the 

Room Schedule title, select Font, change the Font Size to 3/16” and check the Bold box and hit OK. 

Go to the A2.1 sheet view, drag the Room Schedule from the Project Browser onto the sheet. Spread 

the columns out by dragging them so that the writing fits on one line. Name the sheet “FLOOR 

PLANS, SCHEDULES, AND LEGENDS”. 

Video 19 - Open the printer dialog, set Page Size to 30” x 42”, set Paper Placement to Center, Zoom 

to 100%, check the Hide Unreferenced View Tags box, click Export, select Yes in the dialog box, 

name it 30x42 and hit OK. Going back and making adjustments to Room Tag locations (being sure 

that the Leader box is checked), going through the printing process again.  

Lesson 4: 

Video 1 - Introduction to lesson 4. 

Video 2 - Creating an Area Plan - select Area and then Area Plan in the Architecture tab, select Gross 

Building for the Type in the dialog box, hold the control key and select both Level 1 and Level 2 and 

hit OK, select “No” in both of the dialog boxes that pop up. *Open the Level 1 Area Plan in the Project 

Browser, select Area Boundary in the Architecture tab, select the Line tool, draw a line around the 

outside of the exterior walls of the whole building, select Area and then Area in the Architecture tab, 

place the Area tag in the middle of the building, repeat those same steps on Level 2. Since there are 

a couple of areas that are open to below, a couple of additional boundaries will need to be created on 

Level 2 - select Area Boundary in the Architecture tab, select the Rectangle tool, draw rectangles on 

the insides of the walls just where the stairs are, select the Line tool and draw the boundary on the 

insides of the walls and curtain walls at the open area in the Lobby. Then go to Area and then Area in 

the Architecture tab, place the Area tag in the middle of the building. Change the name of both Area 

tags to Level 1 and Level 2. 

Video 3 - Hiding Sections and Grid Lines and adding Color Fill on the Area plans - The first option for 

hiding grid lines: select a grid line and then right click, select Hide in View and then Category. The 

second option is: open Visibility/Graphics Override (VV), select the Annotation Categories tab in the 

dialog box, uncheck the Elevations box and the Sections box and hit OK, turn on and adjust the Crop 

Region (bottom bar), turn off the Crop Region. To add Color Fill - either select Color Fill Legend in the 

Annotate tab or use the Color Scheme in the Properties tab. Select the space next to Color Scheme 

in the Properties tab and an Edit Color Scheme dialog box will appear, select the box under Color to 

open a Color dialog box, select a color and hit OK, and hit OK again and the color will fill in. Change 



the Color Scheme Location in the Properties tab from Background to Foreground and hit Apply to 

color in the furniture. Instead of having to go through this whole process for Level 2, you can select 

View Templates and then Create Template from Current View in the View tab, name it “Gross Area 

Plan” in the New View Template dialog box and hit OK, hit OK after checking the parameters that will 

be included in the View Templates dialog box. *Select Gross Area Plan in the drop down next to View 

Template in the Properties tab, go to the Level 2 Area plan and do the same thing and it will fill with 

color too. Adjust the crop region on Level 2 and then hide the crop region. 

Video 4 - Creating a sheet for the Area plans - select Sheet in the View tab, select the 30 x 42 

Titleblock and hit OK, name the sheet “BUILDING AREA PLANS”, drag the Level 1 and Level 2 Area 

plans onto the sheet from the Project Browser, rename the Level 1 title to “Level 1 - GROSS AREA” 

and select “No” in the dialog box that pops up, Do the same thing for Level 2.  

Video 5 - Creating the Gross Area Schedule - select Schedules and then Schedule/Quantities in the 

View tab, select Area (Gross Building) in the Category list on the New Schedule dialog box that pops 

up, hit OK, select Name and Area from the Available Fields list in the Schedule Properties dialog box, 

then select the Sorting/Grouping tab, check the Grand Totals box and select Title, Count, and Totals in 

the drop down next to it, select the Formatting tab, select Area in the Fields list, select Calculate 

Totals in the drop down on the bottom, select the Appearance tab, check the Outline box and change 

the drop down next to it to Wide Lines, hit OK and the Area Schedule (Gross Building) will open, 

stretch the columns wider by dragging them, highlight the “Area Schedule (Gross Building) title and 

select Font, change the font size to 3/16” and check the Bold box and hit OK. Go to the A2.2 Building 

Area plans view, drag the Area Schedule (Gross Building) onto the sheet from the Project Browser. 

Right click on the schedule and select Edit Schedule, select Edit next to Formatting in the Properties 

tab, select Area under Fields, change Alignment to Right and hit OK. 

Video 6 - Creating the Rental Area plans - select Area and then Area Plan in the Architecture tab, 

select Rentable under Type, select both Level 1 and Level 2 and hit OK, select “No” in both dialog 

boxes that pop up. Open the Level 1 plan under Area Plans (Rentable) in the Project Browser, select 

Area Boundary in the Architecture tab and select the Line tool, draw lines around the whole building 

on the inside face of the exterior walls, draw lines around the stairs on the outside face of the walls, 

do the same for the Lobby and the bathrooms. Select Area and then Area in the Architecture tab, 

select Building Common Areas in the drop down next to Area Type in the Properties tab, tag the lobby 

and the bathrooms, select Major Vertical Penetration from the drop down next to Area Type in the 

Properties tab, tag both of the stairs, then change the Area Type to Office Area and tag the office 

area.  

Video 7 - Change the text on the lobby Area tag to “LOBBY”, do the same for both Stairwells, Office 

Area, and Restrooms. Creating a View Template - select the space next to View Template in the 

properties tab, select Gross Area Plan in the Names list on the dialog box that pops up and hit OK, 

then select Gross Area Plan next to View Template in the Properties tab, select None under the 

Names list and hit OK. Select Color Fill Legend in the Annotate tab, place the Color Fill Legend on the 

drawing and hit OK on the dialog box that pops up, the colors will now be filled in on the drawing. To 

change the colors, select the Color Fill Legend, select Edit Scheme at the top, select Rentable Area in 

the list on the left, click on the color that you want to change and select it in the next dialog box and 

hit OK, select Apply to see the new color on the drawing, and hit OK. Select View Templates and then 



Create Template From Current View in the View tab, name it “Rentable Area Plan” and hit OK, check 

that the correct parameters are checked in the View Template dialog box and hit OK. 

Video 8 - Go to the Level 2 Area Plan (Rentable) view, select Area Boundary in the Architecture tab, 

draw the boundary around the exterior of the building on the inside of the walls, draw the boundaries 

around the stairs and the open area in the lobby and the bathrooms. Select Area and then Area in the 

Architecture tab, select Office Area next to Area Type in the Properties tab and place the tag in the 

office area, select Building Common Area next to Area Type in the Properties tab and place the tag in 

the bathroom area, select Major Vertical Penetration next to Area Type in the Properties tab and place 

the tag in both stairways. Change the area tag names to Stairwell, Restroom, and Office Area. Then 

select the space next to View Template in the Properties tab, select Rentable Area Plan from the 

names list in the Assign View Template dialog box and hit OK. Go back to the Level 1 Area Plan 

(Rentable) view, select Area Boundary in the Architecture tab, use the Line tool to draw a boundary 

for the exterior overhang in front of the lobby, select Area and then Area in the Architecture tab and 

place the Area tag, select Exterior Area next to Area Type in the Properties tab, rename that tag 

“Exterior”. 

Video 9 - Preparing to place the Rentable Area Plans on a sheet - turn on and adjust the crop region 

and then hide the crop region, change the Rentable Area Legend from 1 column to 2 by dragging the 

bottom horizontal extent up until it automatically changes to 2 columns. Drag the Level 1 Area Plan 

(Rentable) from the Project Browser onto the A2.2 Building Area Plans sheet. Do the same thing for 

the Level 2 Area Plan (Rentable). Change the names on the titles to Level 1 (Rentable Area) and 

Level 2 (Rentable Area) and select No in the dialog box that pops up,  

Video 10 - Creating a Rentable Areas Schedule - select Schedules and then Schedule/Quantities in 

the View tab, select Areas (Rentable) in the Category list on the New Schedule dialog box and hit OK, 

select Area Type, Name, Area, and Level from the Available Fields list, go to the Sorting /Grouping 

tab, select Level next to Sort By and check both the Header and Footer boxes and select Title and 

Totals in the drop down next to that and check the Blank Line box next to that, select Area Type in the 

drop down next to Then By, check the Grand Total box and select Title and Totals in the drop down 

next to it, go to the Formatting tab, select Area in the Fields list, change Alignment to Right, select 

Calculate Totals in the drop down on the bottom, select Level in the Fields list, check the Hidden Field 

box, go to the Appearance tab, check the Outline box and select Wide Lines, hit OK and the Area 

Schedule (Rentable) will appear. Drag the columns to widen them, highlight the Area Schedule 

(Rentable) title and select Font, change the font size to 3/16” and check the Bold box and hit OK. Go 

to the A2.2 - Building Area Plans view, drag the Area Schedule (Rentable) onto the sheet from the 

Properties tab, adjust the columns so that all of it is on single lines. 

Video 11 - Showing how it works when you let Revit automatically create the boundary lines.  

Lesson 5: 

Video 1 - Introduction to lesson 5. 

Video 2 - Modifying the curtain wall - go to the 3D view (very top bar), select the horizontal curtain 

wall grid line at the top of the door, select Add/Remove Segments from the top tab, add horizontal 

segments on each side of the door and hit the escape key, select Curtain Grid in the Architecture tab, 



add a grid on the side wall at the same height as the one at the door. I stopped taking so many notes 

here since this is probably not very important for me to try to remember.  

Video 3 - Continuing with modifying the curtain wall. 

Video 4 - Continuing with modifying the curtain wall. 

Video 5 - Continuing with modifying the curtain wall. Creating a new mullion profile.  

Video 6 - Continuing with modifying the curtain wall. 

Video 7 - Creating a new control joint profile.  

Video 8 - Loading the new control joint into the project. Adding vertical control joints to the brick.  

Video 9 - Adding horizontal control joints to the brick.  

Video 10 - Creating a new profile for the metal coping on top of the parapet wall. Adding the metal 

coping to the top of the parapet wall.  

Video 11 - Creating custom geometry for the ceiling. Creating an interior elevation view. Drawing a 

reference plane (RP).  

Video 12 - Continuing to create the custom geometry for the ceiling. Using the Extrusion tool.  

Video 13 - Creating a custom bench.  

Video 14 - Continuing with creating a custom bench. Using the 3D section box to zoom into the 

bench. 

Video 15 - Showing how walls can be set to slant at varying degrees.  

Lesson 6: 

Video 1 - Introduction to lesson 6. 

Video 2 - Creating a Building Section. Adding a footing around the perimeter of the building. Using the 

Join tool to join the geometry of walls, floors, and roof on the elevation drawing. Adjusting the section 

cut lines.  

Video 3 - Adding room tags to the building section. Creating a View Template of the Building Section. 

Using the Join tool to join the geometry of walls, floors, and roof on the elevation drawing. Adjusting 

the view depth of the building section view.  

Video 4 – Creating a wall section of the exterior wall and added additional details. 

Video 5 – Renaming the wall section “Wall Section 1”. Renaming the building sections. 

Video 6 – Creating a new Drafting View and importing a CAD file of a Door Threshold. 

Video 7 – Converting the AutoCad Door Threshold elements into Revit elements. 

Video 8 – Continue with placing Revit details on the CAD Door Threshold detail. 

Video 9 – Creating a footing detail. 

Video 10 – Adding additional details to the footing detail. 



Video 11 – Adding additional details to the footing detail. 

Video 12 – Adding additional details to the footing detail. 

Video 13 – Creating a Window Head detail. 

Video 14 – Adding details to the Window Head detail. 

Video 15 – Adding more details to the Window Head detail. 

Video 16 – Preparing the sheets for printing. 

**** I completed 163 videos at this point. 

BIM 322 – Revit Plumbing (66 videos): 

Lesson 1: 

Video 1 - Introduction to the course. Opening Revit’s Plumbing template file.  

Video 2 - Linking in the Architectural background - select Link Revit in the Insert tab, select and open 

the MEP Architectural file from VDCI’s folder. Checking to make sure that everything is lining up right - 

select Section in the very top bar, draw a vertical section across the building, right click on the section 

and select Go to View, select the level 2 elevation line and click on the dimension, change it to 13’ - 0” 

to match up with the other Level 2 elevation. Go to the 3D view (at the very top bar), note that 2 of the 

levels are part of the Live Model and the other levels shown are part of the Revit link, select 

Copy/Monitor and then Select Link in the Collaberate tab, select the linked part of the Architectural 

drawing, then select Monitor in the panel above, click on level 1 of the live model and level 1 of the 

Revit link, a square symbol will appear in the middle which confirms that they are now linked, then do 

the same thing for level 2. Then select Copy in the panel above, click on all levels except levels 1 and 

2, then hit Finish in the panel above. Hit Escape, and now all of those levels should be part of the live 

model now.  

Video 3 - Go to the Level 1 Plumbing view, click on the model to highlight it, select Edit Type in the 

Properties tab, check the Room Bounding box and hit OK, then select Space in the Analyze tab and 

you can place Spaces manually OR you can select Place Spaces Automatically in the Modify/Place 

Space tab. Do the same thing for Level 2, Then select Space Naming in the Analyze tab, hit OK in the 

Space Naming dialog box. Creating a Space Schedule - select Schedules and then 

Schedule/Quantities in the View tab, select Spaces in the Category list and hit OK, select Level, 

Number, and Name in the Available Fields to add them to the Scheduled Fields, select the 

Sorting/Grouping tab, set Sort By to Level, set Then By to Number, hit OK and the Space Schedule 

will open, select all of the ones with the name “Space” (using the shift key) on both level 1 and level 2, 

select Delete in the tab above and hit OK in the dialog box that pops up. 

Video 4 - Select the File tab and then Open. To find the file - go to My Computer/Local Disk 

(C)/Program Files/Autodesk/Revit 2026/Samples - select the Snowdon Towers Sample Plumbing file 

and hit Open. Go to the 3D view. To turn off all Revit Links - use the keyboard shortcut VV 

(Visibility/Graphics Overrides), select the Revit Links tab, uncheck all of them and hit Apply. Turn on 

Thin Lines (top bar). Showing the settings - select one of the cold water pipes, select Edit Type in the 

Properties tab, select Edit next to Routing Preferences, hit OK twice to get out of that.  



Video 5 - Close all inactive windows and go to the Level 1 Plumbing view. Select Pipe in the Systems 

tab, select Edit Type in the Properties tab, select Duplicate, name it “Copper” and hit OK, select Edit 

next to Routing Preferences, set Copper - K Minimum Size to ¾” and Maximum Size to 6”, hit OK, 

and then hit Apply and OK in the other dialog box. Set the Middle Elevation in the Properties tab to -3’ 

- 6” (to be underground), change the System Type in the Properties tab to Domestic Cold Water, and 

change the Diameter in the Properties tab to 4”. Draw a vertical line into the Mechanical room and hit 

Escape. The pipe is not showing up on the drawing because the pipe is underground. It can be seen 

in the 3D view. Go back to the level 1 plan, select Edit next to View Range in the Properties tab, 

select Associated Level in the drop down next to View Depth Level and set the Offset to -6 - 0”, 

change the Bottom of the Primary Range to -4 - 0”. Hit Apply and OK. The pipe can be seen now. 

Video 6 - select the Section tool at the very top and draw a vertical section next to the water main in 

the Mechanical room. Double click on the section tag to go to that view. Select Tile View (WT) in the 

View tab, close the 3D view and hit (WT) again, Right click on the Drag at the left end of the water 

main in the section view, select Draw Pipe and draw a vertical line straight up, change the Detail 

Level to Fine, adjust the vertical dimension to 9’ - 6”. Right click on the Drag, select Draw Pipe and 

draw a horizontal pipe to the left, set the plan view Detail Level to Fine too. Select the Split Element 

tool in the Modify tab, click 2 points on the vertical pipe in the elevation drawing, delete the section 

between the 2 points, also delete the couplings, drag the upper vertical pipe closer to the wall, draw a 

45 degree offset on the lower pipe, Trim/Extend Single Element (TR) to join the 2 pipes together. 

Video 7 - Go to the Level 1 Plumbing drawing, select Pipe in the Systems tab, double check that it’s 

the correct pipe type, system type, and elevation in the Properties tab, change the Diameter to 3”, 

change the Middle Elevation to 9’ - 6” in the bar just above the drawing, drawing some piping. 

Video 8 - Change the size of the first branch to 2”, also change the line coming out of the end to 2”. To 

change the 90 to 2”, there are 2 choices - change the dimension on one side of the 90 to 2” (all sides 

will then change), or do a crossing over the 90, delete it, and use the Trim tool to join them together 

again. Then select Pipe in the Systems tab again, change the System Type to Domestic Hot Water in 

the Properties tab, draw piping to follow alongside the cold water main. Highlight both the hot and 

cold water tees using the control key, select Selection Box in the panel above, a 3D view of that area 

will open, change the Detail Level to Fine. Go back to the level 1 Plumbing plan. 

Video 9 - Notice the colors of the piping. Click the + symbol next to Piping Systems within Families in 

the Project Browser to expand the group, click on the + again, select Domestic Cold Water and the 

data will appear in the Properties tab, right click on Domestic Cold water in the Project Browser and 

select Type Properties, select Edit next to Graphic Overrides, note that the Pattern and the Weight 

are not given - this is because they are currently governed by the Object Styles of the project under 

the Manage tab. Explaining what all of the other options are. Click OK twice to get out of the dialog 

boxes. Make a crossing (or “drag a window” as this instructor says) over a large part of the middle of 

the building, select Filter, click on Select None, select Pipe Fittings and Pipe in the Categories, hit 

Apply and OK, select Copy to Clipboard, open the level 2 Plumbing plan, select Aligned to Current 

View in the Paste drop down, change the Detail Level to Fine. 

Lesson 2: 

Video 1 - Select Pipe in the Systems tab, set the elevation to 10’ - 6”, this pipe can’t be seen because 

it’s above the View Range, select Edit next to View Range in the Properties tab, change the Top 



Offset to 11’ - 0” and hit OK, drawing more pipes, change the Visual Style to Wireframe in the section 

view. Go to the 3D view, uncheck Section Box in the Properties tab to expand the view, note that you 

can also draw pipe in the 3D view. To change the pipe elevation on the 3D view - be sure to select the 

correct level next to Reference Level in the Properties tab. To Pin the Linked Revit Model so that you 

can be sure that you don’t accidentally move anything - select the whole drawing (everything should 

turn to blue except the plumbing), select the Pin tool in the Modify/Revit Links tab. 

Video 2 - Click Open, select Water Heater in the Families and References folder and Open, select the 

Rheem Water Heater that I downloaded from Rheem’s website (since it is not in the folder that I 

downloaded from VDCI). Select File - then New - then Family - then Open Mechanical Equipment 

(template). Go ahead and save this - click File - Save As - Family - name it BIM - 322 - Water Heater - 

hit Save. Select Extrusion and then the Circle tool, draw a 13” radius circle, click Finish. Double click 

on Front View in the Project Browser, select Reference Plane (PR) in the Create tab, draw a 

horizontal line a few feet high, select Align in the Modify tab, click on the reference plane and the top 

of the cylinder and then lock the padlock, select Aligned Dimension (DI) from the Annotate tab, use 

the tab key to be sure that you’re attaching to the lower Reference Plane and not the Reference 

Level, then click, then click on the upper reference plane, select the top reference plane and then 

enter 6’ - 6” for the dimension. Then select the dimension string, click on Create Parameter (page 

icon with yellow circle at top, to the right of Label), name it “Height” and hit OK. To create a parameter 

for the width - go back to the Reference Level view, select the extrusion that we created, select Edit 

Extrusion in the top panel, select the dimension string, click on Create Parameter (page icon with 

yellow circle at top, to the right of Label), name it “Tank Radius” and hit OK. Click Finish (green check 

mark). Select Family Types in the panel above, note that the Height and Tank Width parameters can 

be seen and changed here, select Height and click Edit (pencil at bottom left of dialog box), rename it 

“Tank Height” and hit OK, and hit OK again.  

Video 3 - Creating a water connection on the tank - select Extrusion and the Circle tool in the Create 

tab, draw a 2” radius circle in the middle and hit Finish (green check mark), open a 3D view, change 

the Visual Style (bottom bar) to Wireframe, raise the new smaller cylinder to the top, go to the Front 

view, then use the Align tool to align the bottom of the new smaller cylinder with the top of the tank 

and lock the padlock. Change the new extrusion height to 2” tall - select it, change the Extrusion End 

to 6’ - 8” in the Properties tab. To be sure that the small cylinder on the top always moves with the 

tank - select Reference Plane (RP) in the Create tab, draw a horizontal line above the top of the tank, 

use Aligned dimension (DI) to measure between the reference plane at the top of the tank to the new 

reference plane, set the dimension to 2” and lock the padlock, select the Align tool, click on the top 

reference line and the top of the small cylinder and lock the padlock. Go to the Front view, select 

Extrusion and the Circle tool from the Create tab, draw a 2” radius circle in the center about 2’ - 0” 

high and hit Finish, go to the 3D view, drag the bottom of the new cylinder up so that it protrudes from 

both sides of the tank, go to the reference level plan, drag the end of the new cylinder to just inside of 

the upper perimeter of the tank, drag the top of the new cylinder down until it’s just above the upper 

perimeter of the tank, go to the 3D view. Select Pipe Connector in the Create tab, click on the faces of 

each of the small cylinders, hit escape twice, select the top connector, select Domestic Cold Water 

next to System Classification in the Properties tab (He got this backwards. The connection at the top 

of the tank should be hot water), also set it to In for the Flow Direction (This is wrong too), select the 

lower connection on the side of the tank and set it to Domestic Hot Water with the Flow Direction set 

to Out (Wrong again). Select Join from the Modify tab, click on the tank and the lower connector on 



the side. Save and then Load into Project. Place 2 water heaters in the Mechanical room using the 

Space bar to rotate them. 

Video 4 - The instructor forgot to size the connectors on the water heaters. So click on one of the 

water heaters and select Edit Family in the panel above, click on the connector on top and change 

the diameter to 1” in the Properties tab, change the connector on the side to 1 ½”, select Load into 

Project, select Yes in the dialog box asking if you want to overwrite. Draw pipes coming out of the 

side of the heaters (right click at the connector and select Draw Pipe), draw the pipes to connect the 

hot water. To connect the cold water - select Pipe in the Systems tab (PI), change the diameter to 1”, 

change the System Type to Domestic Cold Water in the Properties tab, change the Middle Elevation 

to 9’ - 6”, draw in the pipes to connect the cold water to the heaters. Use the Align tool (AL) to make 

the offset and connect the 2 water main ends together.  

Video 5 - Showing how to have a vertical drop automatically added - draw a line at one elevation, 

change the elevation, continue drawing a line and the vertical portion will automatically be added. 

Also showing - use the Tab (or Control) key to select multiple pipes, select the Section Box and it will 

open a condensed 3D view that only shows what was selected. Raised the water mains on both 

levels in the section view to get them above the ceiling. Creating drops for the individual sinks and 

using the Copy tool to duplicate them - create the first set of drops, use Tab select and the Control 

key or drag a window to select all of the pipes and fittings in the one drop, select the Copy tool and 

copy the drops to all of the other locations with the same orientation, then also copy to one of the 

locations with the opposite orientation, use the Rotate tool to rotate it 180 degrees, use the Move tool 

to put it in place, then use the Copy tool to copy the drops to all of the locations with that same 

orientation. 

Video 6 - Select the Trim/Extend Multiple Elements tool in the Modify tab, select the main, and then 

select each branch to tie them in. 

Video 7 - Note that you can use the Align tool to center a pipe drop in a wall. Draw the hot and cold 

water line branches running into the gang bathrooms, use the Tab key (just one click on each item) 

and Control key to select all of them and then Copy to Clipboard, then use Paste - Aligned to 

Selected Levels and select Level 2 to paste them on level 2. Use the Trim/Extend Multiple Elements 

tool in the Modify tab to tie in all of the branches to the water mains on level 1 and level 2. 

Video 8 - Note that you can rotate sections. 

Lesson 3: 

Video 1 - The plumbing fixtures that are currently shown are part of the linked Architectural model. 

Using the Copy/Monitor function allows you to monitor changes that are made by the Architect and 

other trades. The Architect uses plumbing fixture families that do not have connectors on them. When 

loading Autodesk Families, note that there are 2 separate lists of plumbing fixtures - one that doesn’t 

have connectors in the Architectural section, and one that does have connectors in the MEP section. 

Select Copy/Monitor and then Select Link in the Collaborate tab, click on the box that surrounds the 

building in the 3D view, select Coordination Settings in the panel above, set Copy Behavior to Allow 

Batch Copy, set Mapping Behavior to Specify Type Matching, then select Type Matching under 

Plumbing Fixtures in the Category list, we need to load more fixture families before we make changes 

to the In the Host Model list on the Coordination Settings dialog box that pops up, hit Save & Close, 



select Cancel in the panel above. Select Load Autodesk Family in the Insert tab, select Plumbing in 

the Category list, select Lavatories in the MEP section, select Lavatory - Oval and Lavatory - Vanity, 

click on Load. Select Load Autodesk Family again, go up 2 tiers and select MEP in the Categories list, 

select Urinals, select Urinal - Wall Hung, click Load. Select Load Autodesk Family, go up 1 tier and 

select Fixtures, select Water Closets from the Categories list, click Toggle View Type to see a more 

detailed description of each fixture, select Water Closet - Flush Valve - Wall Mounted, click Load. 

Select Load Autodesk Family, go up 1 tier and select Fixtures, select Sinks from the Categories list, 

select Sink - Island - Single, click Load. 

Video 2 - Hover over one of the classroom sinks in the 3D view, use the tab key to toggle until the 

sink is highlighted and then click, select Edit Type in the Properties tab to open the Type Properties 

dialog box, click OK. Select Sink - Island - Single in the Project Browser under Plumbing, then right 

click on the 18” x 18” - Public, select Duplicate, rename the new sink “30” x 21” - Public”, right click on 

it and select Type Properties, change the width to 1’ - 9” and the length to 2’ - 6” and hit OK. Select 

Lavatory - Vanity in the Project Browser, right click on 30” - 18” - Public, select Duplicate, rename it 

48” x 18” - Public, double click to open the Type Properties dialog box, change the width to 4’ - 0” and 

hit OK. Now we are ready to set up Copy/Monitor - select Copy/Monitor and then Link in the 

Collaborate tab, then click on the blue boundary (Architectural link) on the 3D view, select 

Coordination Settings in the panel above, expand Plumbing Fixtures in the Category list, select Type 

Mapping under Plumb=ing Fixtures (** I had to change Mapping Behavior to Specific Type Mapping 

for Fixtures before I could get a Type Mapping option under Plumbing Fixtures in the Category list **), 

in the Host Column - change the Lavatory - Vanity to Lavatory - Vanity : 48” x 18” - Public, change the 

Lavatory-Oval-A to Lavatory - Vanity : Oval 25” x 20” - Public, change the Sink_Kitchen-Single to Sink 

- Island - Single : 30” x 21” - Public, change the Urinal-Wall Hung-A to Urinal - Wall Hung : ¾” Flush 

Valve, change Water closet - Wall Mounted to Water Closet - Flush Valve - Wall Mounted : Public - 1.6 

gpf, * He said to click on Copy in the dialog box, but my Copy button wasn’t highlighted and I couldn’t 

click on it. So instead, I clicked on Save and Close. And then I clicked on the green check mark to 

Finish *. I finally figured out that I could use the Copy command in the panel above to select each 

fixture individually. It appears to be working correctly. When I move a toilet I get a warning from Revit - 

select Finish on the Copy/Monitor tab, select Coordination Review and then Select Link in the 

Collaborate tab, click on the Revit link (surrounding blue box outline), select Move Instance in the 

drop down next to the Relative Position of Two Fixtures Changed message, the toilet will move back 

to its original position and the Coordination Review will be cleared up, hit OK. 

Video 3 - go to the level 1 plumbing view, place a Section on one of the classroom sinks, go to the 

section view, right click on the sink on the floor, select Select All Instances in Entire Project, select the 

Move command, click on the rim of the sink and on the top of the countertop, disregard the warning, 

hit Escape and right click on the sink again, select Select All Instances in Entire Project, move the 

sink by dragging it. Creating a gas system - go to Piping Systems under Families in the Project 

Browser, right click on Other, select Duplicate, rename it Natural Gas, right click on it and select Type 

Properties, click Edit next to Graphic Overrides, select the box next to Color, pick a Cyan color and hit 

OK on the 3 dialog boxes, set size and System Type, draw pipe. 

Video 4 - Adding a gas meter - select Load Family from the Insert tab, select the gas meter from 

VDCI’s folder and hit Open, select Mechanical Equipment in the Systems tab (note that you can also 

select Component in the Architecture tab), place the gas meter using the Space bar to rotate it, go to 



the 3D view, use a section to look at the meter, move the meter up 1’ - 0”, draw pipe from the Global 

Connectors on the gas meter. 

Video 5 - Preparing to put the views on sheets - right click on Level 1 Plumbing and select Duplicate 

View and then Duplicate With Detailing, rename it “1 - Plumbing - Sheet View”, do the same thing for 

Level 2, right on Sheets (all) in the Project Browser and select New Sheet, select Load in the dialog 

box, select the 30 x 42 Horizontal from the VDCI download folder and hit Open, select it in the New 

Sheet dialog box and hit OK, rename it “P-101” on the sheet, rename the sheet “FIRST FLOOR 

PLUMBING” in the project browser and hit OK, right click on the sheet in the project browser and 

select Duplicate Sheet and then Duplicate Empty Sheet, renumber the duplicated sheet “P-102” in the 

project browser and rename it “SECOND FLOOR PLUMBING” and hit OK, drag the Level 1 Plumbing 

- Sheet View onto the P-101 sheet, change the View Scale in the Properties tab to 3/32” = 1’ - 0” and 

hit Apply, do the same thing for the Level 2 Plumbing. While on the P-102 sheet (with the view 

highlighted), name the Title on Sheet as “LEVEL 2 PLUMBING” in the properties tab. Do the same 

thing for the P-101 sheet. Turning off the elevations - click the view on the sheet, type VV 

(Visibility/Graphics Overrides), select Annotation Category, uncheck the Elevations box and hit OK. 

Creating a View Template - go to the Level 2 Plumbing Sheet View, type VV, uncheck Room 

Separators (if you have them), to be continued in the next video. 

Video 6 - continued from the last video - right click on Level 2 Plumbing - Sheet View in the project 

browser and select Create View Template From View, name it PLUM-FLOOR PLAN and hit OK, hit 

OK again in the dialog box that pops up, then click on the box next to View Template in the Properties 

tab, select PLUM-FLOOR PLAN in the Names list and hit OK. Then go to the Level 1 Plumbing - 

Sheet View, click on the box next to View Template in the Properties tab, select PLUM-FLOOR PLAN 

and hit Apply and OK. Click on the box next to View Template in the properties tab, click on the box 

next to View Range in the dialog box that popped up, set the Top Offset to 12’ - 0” and hit OK twice. If 

you want the drawing to be a single line diagram for documentation purposes - click on the box next 

to View Template in the properties tab, change the Detail Level to Medium and hit OK. Create a Guide 

Grid to ensure that the different floor levels appear on their respective sheets in the same location on 

each sheet - select Guide Grid in the View tab while on the P-101 - FIRST FLOOR PLUMBING sheet 

view, make SURE that you’re not clicked into the view or the Guide Grid button will not work!, name 

the Guide Grid “Overall”, double click on the view, select Reference Plane (RP), draw horizontal and 

vertical reference planes from the top left corner of the building with the lines running out, right click 

and select Deactivate the View, select Move (MV), click on the corner of the building and one of the 

nearby grid intersections, reduce the size of the grid by dragging the sides until that one grid 

intersection is the only one that you can see, go to the P102 - SECOND FLOOR PLUMBING view, 

select Overall in the box next to Guide Grid in the properties tab and hit Apply, click on the view, 

select (MV), click on the corner of the building and then the Guide Grid intersection. 

Video 7 - printing the project for the midterm grade.  

Lesson 4: 

Video 1 - Drawing sloped drainage piping - select Pipe Type in the properties tab, select Edit Type, 

select Edit next to Routing Preferences, change Elbow, Preferred Junction Type, Transition, etc. to 

the appropriate fittings and hit OK, change System Type to Sanitary. 



Video 2 - Drawing pipe. Using the Section Box to adjust fittings (good example of rotating a fitting and 

using the Trim/Extend tool).  

Video 3 - Using the Inherent Elevation setting to tie in the waste branches.  

Video 4 - Drawing more pipe.  

Video 5 - Showing an example of using the Align tool (AL) to center the pipes in the walls.  

Video 6 - Drawing more pipe.  

Video 7 - Changing the View Depth on level 2 so that the pipe below the floor becomes visible on 

level 2,  

Video 8 - Drawing more pipe.  

Video 9 - Working using the Tiled Window (WT) view.  

Video 10 - Inserting P-traps on the lavatory drain connections. 

Video 11 - Connecting water and drains to sinks and lavatories. 

Video 12 - Connecting water and drains to the classroom sinks.  

Video 13 - Connecting water and drains to the classroom sinks.  

Lesson 5: 

Video 1 - Aligning all of the pipes in the walls. 

Video 2 - Connecting the water pipes for the classroom sinks using the Trim tool in the 3D view.  

Video 3 - Changing the fitting types used - downloading Revit families and changing the Routing 

Preferences. Changing the fitting types that have already been drawn - right click on one fitting and 

then select All Instances in Project, click on the fitting type in the Properties tab and change it to the 

desired fitting. Connecting the classroom sink drains to the stacks in the 3D view. Turning off the 

Architectural link to see the plumbing system more clearly in the 3D view - select Graphics/Overrides 

(VV), uncheck the MEP Architectural box in the Revit Links tab.  

Video 4 - Connecting more classroom sink drains in the 3D view.  

Video 5 - Drawing the water pipe for the lavatories in the bathrooms.  

Video 6 - Drawing the water pipe for the lavatories in the bathrooms in the 3D view. Using the Trim 

tool extensively. Using the System Browser - select User Interface in the View tab and then check the 

System Browser box, you can then see the system information regarding assigned/unassigned items 

and GPM flow rates.  

Video 7 - Using Tab Select to change sizes of multiple segments of pipe, Using Create Similar to add 

a p-trap.  

Video 8 - Connecting lavatory drains in the Section view. 



Video 9 - Creating the sanitary vent system. Changing 1/4 bends to tees. Note that when transitioning 

to different system type (i.e. sanitary line turning into a vent) it works better in the Section view than it 

does in 3D.  

Video 10 - Adding p-traps for the urinals. Setting a pipe length while drawing a pipe - enter the 

dimension after beginning to draw the pipe. 

Video 11 - Running vents for the bathrooms. Selecting multiple pipes and setting the elevations at the 

same time. 

Video 12 - Connecting the vents for the bathrooms. Changing a tee to a ¼ bend. Using the 

Trim/Extend Multiple Elements tool. 

Video 13 - Running the vents up through the roof. Changing the stacks above the level 2 classroom 

sink connections to vent stacks - delete the segments first and then redraw them as vent pipes.  

Video 14 - Drawing the vent stacks in for the classroom sinks. Adding ridiculous ‘revents’ for the level 

1 classroom sinks. 

Video 15 - Continuing to run the vent stacks for the classroom sinks through the roof. Assigning a 

color and a line style for the vent system - expand the Families group in the Project Browser, expand 

Piping Systems, right click on Vent and select Type Properties, click Edit next to Graphic Overrides, 

select a color, and then select Dash Dot Dot 1/8 (or whatever) for the Pattern. 

Video 16 - Reviewing/adjusting the model for any issues or problems (checking in the 3D view). 

Adding insulation to the hot water system - use tab select in the 3D view to select the entire hot water 

system, select Add Insulation from the panel above. To adjust the appearance of the insulation - 

select Visibility/Graphics Overrides (VV), click on the box under Transparency in the Pipe Insulations 

row, change the Transparency to 75 (or whatever). 

Lesson 6: 

Video 1 - Creating new sheets - right click on Sheets in the project browser, select New Sheet, select 

the E1 30” x 42” Horizontal. Right click on the new sheet in the project browser and select rename. 

Set Number to P-001 and Name it PLUMBING TITLE SHEET. Then create 4 more new sheets. Note 

that you can also use the Function 2 key to rename the sheets, just as you can with renaming files 

and folders in Windows. Go to the Level 1 Plumbing Sheet view and select Callout in the View tab. 

Create Callouts around the water heaters in the mechanical room and also the gang bathrooms. 

Move the callout tags so that the leader winds up with an angle and a turn. Go to the level 2 Plumbing 

Sheet view and draw a callout around the gang bathrooms. Rename Callout 1 in the project browser 

to LEVEL 1 - ENLARGED MECHANICAL ROOM. Rename callout 2 to LEVEL 1 - ENLARGED 

BATHROOMS. Rename the callout for level 2 to LEVEL 2 - ENLARGED BATHROOMS. Go to the P-

401 sheet and drag the 3 enlarged plans onto it. Creating a new View Template - select 1 of the views 

on the sheet and then select the Plumbing Plan in the box next to View Template in the properties tab, 

select the Duplicate button on the lower left corner of the dialog box, name it Plumbing Enlarged Plan 

- ¼”, change the View Scale to ¼” and hit OK, and then for each of the other 2 views on the sheet - 

click on the view, select Plumbing Plan next to View Template and change the scale to ¼”. Select all 3 

views on the sheet and uncheck the Crop Region box in the properties tab. To change the titles on 



each of the views - select a view on the sheet, type in your title in the box next to Title on Sheet in the 

properties tab.  

Video 2 - Working on the new sheets. To hide the sections on the sheets - select View Template in the 

properties tab, select Plumbing Enlarged Plan in the Names list of the dialog box, select Edit next to 

V/G Overrides Annotation, uncheck the box next to Sections and hit OK. Putting space tags on the 

enlarged views - select Space Tag in the Annotate tab. Tagging the pipe sizes - select Tag by 

Category in the Annotate tab. Assigning pipe tag abbreviations - go to Piping Systems under Families 

in the project browser, select a piping system, right click and select Type Properties, type in your 

abbreviation in the box next to Abbreviation and hit OK. Editing the pipe tags - select a pipe tag, 

select Edit Family in the panel above, click on Size in the window and select Edit next to Label in the 

properties tab, select System Abbreviation in the Category Parameters list, (I also selected Spot 

Bottom Elevation), change the Sample Value next to System Abbreviation to “?”, then add a space in 

the Suffix box next to Size and hit OK, then select Load into Project and Overwrite the existing 

version (I also checked the Break box on System Abbreviation, inserted “BOP= “ in the Prefix for Spot 

Elevation, and put a “?” in the Sample Value column, and checked the Wrap Between Parameters 

Only box at the top. I also removed the 0 with the slash through it (denoting diameter) by selecting 

Mechanical Settings under the drop down for MEP Settings in the Manage tab, then selecting Pipe 

Settings in the list, and deleting the 0 with the slash through it on the Pipe Suffix line. I also 

horizontally aligned the writing to the left.). (I also rounded off the BOP dimensions to the nearest 1/8” 

on the pipe tags - select one of the tags and select Edit Family in the ribbon, click on the label in the 

window, select Edit Label in the ribbon, select Spot Bottom Elevation on the parameter list, click on 

the icon to the right of the E with the arrow pointed down, set the Rounding to the nearest 1/8”). (I 

also changed the settings to always put the pipe tag text horizontal - click on a pipe tag, select Edit 

Family in the ribbon, DON’T select anything in the view, uncheck the Rotate with Components box, 

then Load into Project and click OK on Overwriting).  

Video 3 - Continuing to tag (TG) the pipe sizes.  

*Video 4 - Tagging the fixtures - select Tag by Category (TG), clicking on a fixture won’t produce 

anything on the tag without it being defined yet. To define the fixtures first - click on a classroom sink 

and select Edit Type in the properties tab, then enter “S1” in the Value next to Type Mark and hit OK, 

OR, click on the blank fixture tag and enter S1 (I also set my Leader Type to Free End and changed 

the leader arrowhead to 1/16” Dot Filled). Turning off the plumbing fixtures in the Revit link so that you 

don’t accidentally select them - select the View Template in the properties tab, select PLUM-FLOOR 

PLAN in the Names list, select Edit next to V/G Overrides RVT Links, select By Host View under 

Display Settings, select the Custom button, select the Model Categories tab, change Model 

Categories to Custom in the drop down, uncheck the box for Plumbing Fixtures in the Visibility 

column and hit OK. To reveal the underground piping - select View Template in the properties tab, 

select Edit next to the View Range parameter, change the View Depth to -4’ - 0” and hit OK (I kept 

mine the same because I wanted the underground piping on a separate sheet). Changing the line 

style for the underground piping to differentiate it from the above ground piping - create a Filter first - 

select the View Template, select Edit next to V/G Overrides Filters, select Edit/New at the bottom left 

corner, select New (page icon w/ yellow circle), name it Underground Piping and hit OK, check the 

Pipes box in the Categories list, select Upper End Centerline Elevation in the drop down next to Pipes 

under Filter Rules, select Is Less Than in the drop down under Pipes, enter 0’ - 0” in the box to the 



right and hit OK, then select Add and choose Underground piping and hit OK, click on Override under 

Lines, select Dash 1/16” in the drop down for Pattern and hit OK. Adding Spot Slope tags. Adjusting 

the View Range in order to hide/reveal piping below floors. 

Video 5 - Using the Add/Remove Host tool to tag multiple pipes/fixtures with one tag.  

Video 6 - Continuing to tag pipes, fixtures, gas meter, and water heaters. Adding Text Notes (such as 

for pipes going up or down) - select Text (TX) in the Annotate tab, change the text font size to 3/32” in 

the properties tab.  

Video 7 - Creating Section Views to put on the sheets. Creating a Sub Discipline parameter so that 

the section views can be sorted - select all of the section views in the project browser, select 

Plumbing in the box next to Sub-Discipline in the properties tab, click on each of the sections 

individually and name them in the box next to View Name in the properties tab. Set the scale to 1/8” = 

1’ - 0” in the properties tab for each of the section views on the sheet. Creating a View Template for 

the elevation drawings - right click on one of the sections in the project browser and select Create 

View Template From View, name it Plumbing Section - 1/8” and hit OK, hit OK on the other dialog box 

too, then click on the box next to View Template in the properties box, then select Plumbing Section - 

1/8” and hit OK, then apply that same View Template to any other section views by clicking on it in the 

properties tab. Putting pipe tags on the elevation views. Putting Space Tags on the elevation views.  

*Video 8 - Creating a 3D isometric view for the sheets - right click on the 3D view in the project 

browser and select Duplicate View and then Duplicate with Detailing (He didn’t say to do this, but you 

also need to turn off everything except plumbing items in Visibility/Graphics Overrides.). Rename the 

3D (Copy) view to PLUMBING ISOMETRIC in the project browser. Change it to a Coarse detail level. 

Crop the view. Go into Visibility/Graphics Overrides (VV) and uncheck the Levels box in the 

Annotation tab and hit OK to turn off the level lines in the 3D drawing. Create a new sheet for the 

isometric view and name it P-701 and PLUMBING ISOMETRIC. Put the 3D view onto the sheet. 

Locking the 3D view so that it can be tagged - click on the Lock 3D View button (little house) at the 

bottom left. Using the Tag All tool to tag all of the fixtures on the 3D drawing - select Tag All Not 

Tagged in the Annotation tab, select Plumbing Fixture Tag, check the Leader box and set it to ¼” and 

hit OK. Changing the detail level of the plumbing fixtures to Fine on the 3D view while leaving all of 

the piping set to coarse - go to Visibility/Graphics Overrides (VV), change the Detail Level for 

Plumbing Fixtures to Fine and hit OK.  

Video 9 - Continuing to tag the fixtures on the 3D view. Creating a Scope Box. 

Video 10 - Duplicating the 3D view. Rename it TITLE SHEET IMAGE. Select Visibility/Graphics 

Overrides (VV), turn back on the Revit Link by checking the box next to MEP Architectural in the Revit 

Links tab, then uncheck all boxes in the Annotation tab and hit OK. Then put the Title Sheet Image 

onto the Title Sheet and change it to 1/16” = 1’ - 0”. Adding the Legend to the Title sheet - select 

Insert From File in the Insert tab, go to the Families and References folder in the BIM 322 folder and 

open the Details and Schedules file, then select Water Hammer Arrestor, Trap Primer, Standard Valve 

Detail, and the Plumbing Legend and hit OK, hit OK on the dialog box that pops up, change the 

Discipline for each of those items to Plumbing in the properties tab, then put each of them onto the 

Title sheet. Remove the title on the Plumbing Legend view on the Plumbing Title sheet - click on the 

legend, select Edit Type in the properties tab, select Duplicate and rename it No Title, change the box 



next to Title to None, uncheck the box next to Extension Line and hit OK. Adding the details to the 

Detail sheet. 

Video 11 - Explaining the benefits of saving detail views for use on other projects. Creating a 

plumbing fixture schedule - select Schedules and then Schedules/Quantities in the View tab, select 

Plumbing Fixtures in the Categories List and hit OK, select Type Mark, Family, Type, Manufacturer, 

Model, Type Comments from the Available Fields list, select Type Mark next to Sort By in the 

Sorting/Grouping tab, change Alignment to Center for the first 4 items in the Fields list in the 

Formatting tab, check the Outline box and change the line weight to DETAIL LW 3 in the Appearance 

tab, change the Title Text to ¼” Arial, the Header Text to 3/32” Arial, and the Body Text to 3/32” Arial 

and hit OK. Select Edit next to Fields in the properties tab, uncheck the Itemize Every Instance box in 

the Sorting/Grouping tab and hit OK. Expand the columns on the fixture schedule as needed. Adding 

Manufacturer names for the fixtures. Change the titles for each of the columns to MARK, 

DESCIPTION, SPECIFICATIONS, MANUFACTURER, MODEL, COMMENTS. Change the title to all 

capital letters. 

Video 12 - Putting the schedules on the Schedules sheet. Creating a Mechanical Equipment schedule 

- select Schedules and then Schedule/Quantities in the View tab, select Mechanical Equipment in the 

Category List and hit OK, select Mark, Family, Manufacturer, Model, and Type Comments in the 

Available Fields list and hit OK, select Edit next to Sorting/Grouping in the properties tab, select Mark 

next to Sort By, uncheck the Itemize Every Instance box and hit OK, select Edit next to Appearance in 

the properties tab, check the Outline box and set it to DETAIL LW 3, set the Title Text to ¼” Arial and 

3/32” Arial for Header Text and Body Text and hit OK, change the column headings to MARK, 

DESCRIPTION, MANUFACTURER, MODEL, and COMMENTS, change the title to all capital letters. 

To change the name in the Description column - right click on the item in the Families area in the 

project browser and rename it. Select Edit next to Formatting in the properties tab, set the alignment 

to Center for the top 4 items in the Fields List and hit OK. Put the Mechanical Equipment Schedule 

onto the Schedules sheet. 

Video 13 - Editing the font size for the sheet name label - click on the sheet and then select Edit 

Family, select the Sheet Name on the sheet and change the font size by clicking Tag Label in the 

properties tab. Printing the sheets for the final.  

 


